*

IPv6 là gì

Lịch sử thành lập của IPv6 (từ viết tắt của mạng internet Protocol 6) khá lâu. Đó là vào năm 1981, khi các máy tính số đông chỉ hoàn toàn có thể truy cập internet ship hàng cho các tổ chức nghiên cứu quân sự. Với môi trường thao tác làm việc 8 bit, kết hợp với không gian địa chỉ 32 bit vị phiên bạn dạng Internet Protocol 4 (viết tắt là IPv4) cung cấp chất nhận được kết nối tới 4 tỷ địa chỉ cửa hàng khác nhau. 

Trải qua ngay sát 30 năm, sự cách tân và phát triển của công nghệ đã tạo thành bước bỗng phá, mạng internet tồn tại trên khắp nỗ lực giới khiến con số địa chỉ đã gần tới mức cực đại. Đồng thời, nó còn dự báo rất có thể vượt giới hạn của IPv4. Về lý thuyết, nếu như vượt mức è thì khả năng kết nối internet sẽ không thể vận động được. Chính vấn đề đó đã tạo động lực thúc đẩy việc nghiên cứu, cải tiến và phát triển giao thức mới, giúp giảm bớt nhược điểm trên.

Bạn đang xem: Cài đặt ipv6 cho win7

Đầu trong thời gian 1990, IETF cải cách và phát triển một giao thức mới có tên gọi là IP Next Generation (IPng). Và vào khoảng thời gian 1998, giao thức này chính thức chuẩn hóa, được Tổng công ty Internet đến tên miền cùng số (viết tắt là ICANN) phê duyệt, cho phép sử dụng trên thoáng rộng trên toàn cầu. Giao thức chọn cái tên IPv6 (RFC 1883).

IPv6 thành lập đã giải quyết được những giảm bớt tồn tại của IPv4 trong hệ thống internet, tạo ra bước tiến khiêu vũ vọt của công nghệ số.

Các điểm đổi mới của IPv6 đối với IPv4:

không khí lưu trữ lớn. IPv4 có không khí truy cập 32 bit, tương đương 4 tỷ địa chỉ. Còn IPv6 có không khí là 128 bit, lớn hơn gấp 4 lần đối với IPv4. Độ bảo mật cao hơn. Năng lực định con đường được tăng cao. Cấu hình được thi công theo hướng dễ dàng hơn đối với IPv4.

Lợi ích của IPv6 connectivity

Các tiện ích mà IPv6 đã cùng đang sở hữu đến cho những người dùng đó là:

có thể chấp nhận được không gian showroom lớn, giúp việc thống trị không gian này trở nên thuận lợi hơn. Quản lí trị dễ dãi hơn. Vì chưng IPv6 có khả năng auto cấu hình mà không đề nghị đến sever DHCP. Trong những khi đó, IPv4 đề nghị DHCP để cấu hình. Định tuyến đường IPv6 có thiết kế phân cấp nên kết cấu tốt. IPv6 hỗ trợ tốt rộng về Multicast. Việc thu xếp và định dạng header được thực hiện khoa học và tối ưu giúp việc bảo mật tin tức được đổi mới hơn. IPv6 cung ứng tốt cho những thiết bị di động.

Cấu trúc địa chỉ IPv6

Cấu trúc của IPv6

Cấu trúc của một IPv6 có 128 bit, được tạo thành 8 nhóm. Vào đó, mỗi nhóm tất cả 16 bit với được phân loại bởi lốt “:”.

Một add IPv6 được mô tả theo kết cấu sau:

FEDC:BA98:768A:0C98:FEBA:CB87:7678:1111:1080:0000:0000:0070:0000:0989:CB45:345F

Vì cấu trúc quá lâu năm nên tín đồ ta thường bỏ số 0 sống đầu từng nhóm nhằm rút gọn. Đối với đội nào chỉ gồm duy nhất dãy số 0 thì nó sẽ được biểu diễn bằng dấu “::”

*

Cấu trúc của Address Prefixes

Address Prefixes có cấu trúc tương từ bỏ IPv4 CIDR. Giải pháp thể hiện của nó là IPv6-address/ prefix-length. 

Trong đó:

- IPv6-address: Địa chỉ IPv6 với mức giá trị bất kỳ.

- Prefix-length: Số bit gần kề nhau trong prefix.

Ví dụ: Quy tắc biểu diễn của 56 bit prefix 200F00000000AB là

200F::AB00:0:0:0:0/56

200F:0:0:AB00::/56

Lưu ý: Với showroom IPv6, kí hiệu “::” chỉ được dùng duy độc nhất 1 lần vào một sự biểu diễn.

Các yếu tố của IPv6

Địa chỉ IPv6 có 3 thành phần: site prefix, subnet ID và interface ID. Vào đó:

Site prefix: Đây là thông số được gán với website trải qua ISP. Vì chưng đó, toàn máy bộ tính ở thuộc vị trí sẽ chia sẻ với nhau bởi một site prefix. Có thể thấy, tính năng của site prefix là khi đã nhận được ra mạng của người tiêu dùng và chất nhận được truy cập trải qua internet thì nó sẽ đào bới việc cần sử dụng chung. Subnet ID: Đây là thành phần bên phía trong website. Nó được sử dụng để miêu tả cấu trúc site của mạng. Vì chưng thế, một IPv6 subnet sẽ có cấu tạo tương đương một nhánh mạng đơn. Interface ID: cấu tạo của nó tựa như ID trong IPv4. Các thông số sẽ nhận dạng một host riêng. Interface ID có thông số kỹ thuật tự động. 

Ví dụ: Địa chỉ IPv6 có cấu trúc: 2001:0f68:0000:0000:0000:0000:1986:69af bao gồm:

- Site prefix: 2001:0f68:0000

- Subnet ID: 0000

- Interface ID: 0000:0000:1986:69af
*

Phân loại địa chỉ IPv6 connectivity

Có 3 loại địa chỉ cửa hàng IPv6:

Unicast: Một địa chỉ Unicast được chỉ định và hướng dẫn riêng cho 1 cổng của node IPv6. Khi có một gói tin nhờ cất hộ đến add Unicast, nó đang được mang đến cổng đã hướng dẫn và chỉ định bởi showroom đó. Multicast: Đây là nhóm các cổng IPv6. Lúc 1 gói tin nhờ cất hộ đến địa chỉ cửa hàng Multicast thì nó sẽ được toàn bộ thành viên trong team multicast xử lý. Anycast: Đây là địa chỉ cửa hàng đăng ký kết cho nhiều cổng (tức trên nhiều node). Khi có gói tin nhờ cất hộ đến địa chỉ cửa hàng Anycast, nó sẽ được chuyển cho một cổng bất kỳ, tuy nhiên, phần nhiều là cho cổng gần nhất.

Hướng dẫn cách đặt showroom IPv6 mang lại win 7, 8, 10

Để đặt add Ipv6 cho win 7, 8, 10, bạn tiến hành như sau:

cách 1: Click vào biểu tượng Window, chọn tiếp Run. Trong hành lang cửa số Run, nhập dòng chữ ncpa.cpl. Bước 2: các bạn chọn thẻ mạng mong gán IPv6, tiếp nối chọn tiếp Properties. Bước 3: liên tiếp chọn internet Protocol Version 6 (TCP/IPv6), rồi lựa chọn Properties.
*
cách 4: Bạn triển khai điền các thông số giá trị IPv6 của phòng cung cấp (tham khảo hình mặt dưới). 
*
cách 5: sử dụng câu lệnh ipconfig sống cmd để thực hiện ping kiểm tra tác dụng IPv6. Bằng cách, mở cmd, gõ tiếp lệnh ipconfig. Thời gian này, một hành lang cửa số hiển thị như hình sau.
*

Kế đến, sử dụng dòng lệnh ping -6 ipv6.google.com để khám nghiệm IPv6:

*

Nếu hệ thống hiển thị hiệu quả trả lời có nghĩa là bạn đã thiết lập thành công add IPv6.

Hướng dẫn cách áp dụng IPv6 - đặt showroom IPv6 trải qua Remote UI

Các làm việc thực hiện tại đặt showroom IPv6 bằng cách sử dụng Remote UI được tiến hành như sau:

cách 1: các bạn khởi động Remote UI và đăng nhập vào hệ thống. Bước 2: Click chọn thư mục Setting/Registration nghỉ ngơi cột bên yêu cầu như hình sau.
*
cách 3: vào bảng hiện nay ra, click lựa chọn Network Setting, rồi lựa chọn tiếp TCP/ IP Settings.
*
bước 4: tại mục IPv6 Setting, bạn click lựa chọn Exit.
*
cách 5: hôm nay một bảng thoại xuất hiện. Các bạn chọn hộp kiểm tra rồi tiến hành thông số kỹ thuật cài đặt.
*
cách 6: Khi vẫn hoàn tất thiết lập ở cách 5, các bạn click OK để kết thúc setup IPv6.

Cấu hình IPv6 trên Router Cisco

Các bước thực hiện như sau:

bước 1: Tiến hành cấu hình IPv4, giao thức OSPFv2 trên những Router Thename cùng Thename1. Đây là phần đa tên router trả định nhưng Hosting Việt đặt cho ví dụ minh họa sau để bạn dễ hiểu. Vào thực tế, bạn có thể đặt thương hiệu tùy ý theo nhu cầu sử dụng.

- Thename: 

Cú pháp câu lệnh thực hiện:

Thename#config terminal

Thename(Config)#interface fastethernet 0/0

Thename(Config-if)#ip address 192.168.12.1 255.255.255.0

Thename(Config-if)#no shut

Thename(Config-if)#interface loopback 0

Thename(Config-if)#ip address 1.1.1.1 255.255.255.255

Thename(Config-if)#no shut

Thename(Config-if)#interface fastethernet 0/1

Thename(Config-if)#no ip address

Thename(Config-if)#ipv6 enable

Thename(Config-if)#ipv6 address 2000::1/64

Thename(Config-if)#no shut

Thename(Config-if)#exit

Thename(Config)#router ospf 100

Thename(Config-router)#network 1.1.1.1 0.0.0.0 area 0

Thename(Config-router)#network 192.168.12.0 0.0.0.255 area 0

- bên trên ISP:

Cú pháp câu lệnh:

ISP#config terminal

ISP(Config)#interface fastethernet 0/0

ISP(Config-if)#ip address 192.168.12.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#interface fastethernet 0/1

ISP(Config-if)#ip address 192.168.23.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#exitISP(Config)#router ospf 100

ISP(Config-router)#network 192.168.12.0 0.0.0.255 area 0

ISP(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Hình sau là bảng định con đường IPv4 trên Thename.

Xem thêm: Từ Vựng Tiếng Anh Về Gia Đình Có Phiên Âm, Tổng Hợp Từ Vựng Tiếng Anh Về Gia Đình

*

- Thename1

Cú pháp câu lệnh:

Thename1#config terminal

Thename1(Config)#interface fastethernet 0/0

Thename1(Config-if)#ip address 192.168.23.3 255.255.255.0

Thename1(Config-if)#no shut

Thename1(Config-if)#exit

Thename1(Config)#router ospf 100

Thename1(Config-router)#network 192.168.23.0 0.0.0.255 area 0

Dưới đấy là bảng định đường IPv4 trên Thename1.

*

Lúc này, những mạng IPv4 đã hoàn toàn có thể thấy và kết nối với nhau.

bước 2: chế tạo ra interface tunnel 0 bên trên Thename cùng Thename1 

- Thename

Câu lệnh:

Thename(config)#ipv6 unicast-routing

Thename(config)#interface tunnel 0

Thename(config-if)#ipv6 address 3000::1/64 eui-64

Thename(config-if)#no ipv6 nd suppress-ra

Thename(config-if)#tunnel source loopback 0

Thename(config-if)#tunnel mode ipv6ip isatap

Để chất vấn Tunnel vừa tạo, bạn dùng lệnh show ipv6 interface brief.

*

Theo hình trên, Thename có add IPv6 của tunnel 0 là 3000::5EFE:101:101

- Thename1:

Cú pháp câu lệnh như sau:

Thename1(Config)#interface tunnel 0

Thename1(Config-if)#ipv6 enable

Thename1(Config-if)#ipv6 address autoconfig

Thename1(Config-if)#tunnel mode ipv6ip

Thename1(Config-if)#tunnel source fastethernet 0/0

Thename1(Config-if)#tunnel destination 1.1.1.1

Để kiểm soát tunnel 0 vừa tạo, bạn cũng thực hiện câu lệnh tương tự như bên trên là cần sử dụng lệnh show ipv6 interface brief.

*

Theo bảng trên, add IPv6 của tunnel0 bên trên Thename1 là 3000::C0A8:1703

bước 3: tiến hành định tuyến đường tĩnh trên các router IPv6 để những mạng bé thấy nhau, bằng phương pháp dùng câu lệnh ipv6 route x:x:x:x::x/ next-hop hoặc interface.

- Thename: Thename(config)#ipv6 route 4000::/64 3000::c0a8:1703

- Thename1: Thename1(config)#ipv6 route 2000::/64 3000::5efe:101:101

Sau đó, chúng ta kiểm tra những bảng định tuyến.

Hình sau là bảng định đường IPv6 bên trên Thename.

*

Dưới đấy là bảng định tuyến đường IPv6 trên Thename1.

*

bước 4: Thực hiện setup IPv6 cho những host cùng ping để kiểm tra kết nối

Cách thực hiện như sau:

- Đặt IPv6 cho máy tính xách tay sử dụng Window Vista, 7, 8, 10, bạn tiến hành như khuyên bảo cách đặt add IPv6 làm việc mục trên. Đó là vào Start / chọn Control panel / lựa chọn tiếp Network và Internet / click lựa chọn Network và Sharing Center /click mục Change adapter setting / và chọn Properties Local Area Connection / sau đó, click vào internet Protocol Version 6 để mua đặt địa chỉ IPv6.

Đặt IPv6 cho máy tính sử dụng Window XP: Click vào nút Start / gõ Cmd vào thanh tìm kiếm / kích hoạt nhân kiệt IPv6 bằng phương pháp gõ câu lệnh “netsh interface ipv6 install”. Sau đó, dùng tiếp lệnh “netsh interface ipv6 add address “Local Area Connection” 2000::2/64” để đặt địa chỉ cửa hàng IPv6.
*

Sau khi hoàn chỉnh đặt add IPv6 cho host, bạn triển khai ping để bình chọn kết nối:

- Kiểm tra kết nối từ host 1 mang lại host 2

*

- Kiểm tra kết nối chiều trái lại từ host 2 mang lại 1

*

Lúc này, 2 host sẽ thấy nhau. Đây là hướng dẫn về cách dùng vẻ ngoài ISATAP tùy chỉnh cấu hình kết nối của IPv6 là gì. Quy mô mạng này tương đối đơn giản và dễ dàng và bạn dễ dàng mở rộng với tương đối nhiều router không giống nhau, kết hợp sử dụng định tuyến thời thượng hơn.

Ngoài ra, bạn cũng nên chú ý là trước khi dùng ping để soát sổ kết nối, các bạn phải bảo đảm Window Firewall đã làm được tắt. 

Bài viết liên quan

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *